
Dear customer 
 
LAPIS Semiconductor Co., Ltd. ("LAPIS Semiconductor"), on the 1st day of October, 
2020, implemented the incorporation-type company split (shinsetsu-bunkatsu) in which 
LAPIS established a new company, LAPIS Technology Co., Ltd. (“LAPIS 
Technology”) and LAPIS Technology succeeded LAPIS Semiconductor’s LSI business. 
 
Therefore, all references to "LAPIS Semiconductor Co., Ltd.", "LAPIS Semiconductor" 
and/or "LAPIS" in this document shall be replaced with "LAPIS Technology Co., Ltd." 
 
Furthermore, there are no changes to the documents relating to our products other than 
the company name, the company trademark, logo, etc.  
 
Thank you for your understanding. 
 

LAPIS Technology Co., Ltd. 
October 1, 2020 



 
Starter Kit for Ultra Low Power Microcontroller 

ML62Q1000 MCU Starter Kit Start Guide 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 1  ML62Q1000 MCU Starter Kit hardware configuration. 
 
 
 
 
■ Use with the U8/U16 Development Tools 

This section will take you through the process of building the ML62Q1000 Blink LED Sample, loading to the ML62Q1577 and 
running. 

 

 
 
 
 
 
 
 

Figure 2  Use with the U8/U16 Development Tools configuration. 

 
 
1. Copy of ML62Q1000 MCU Starter Kit Software Package to your PC 
1-1. Insert the “ML62Q1000 MCU Starter Kit Software Package” DVD into the DVD drive of your PC. 
1-2. Copy the “ML62Q1000_MCU_ StarterKit” folder in the DVD to the C drive’s root folder (C:\) of your PC. 

• Please copy the “ML62Q1000_MCU_StarterKit” folder to the folder the name of which is using half-width characters 

except space if you do not copy it to the C drive’s root folder (C:\) of your PC. 
 
1-3. Eject the DVD from the DVD drive of your PC 

 
 
2. Installing U8/U16 Development Tools 

This section will take you through the process of installing the U8/U16 Development Tools software, the Multiple Flash Writer, the 
Device Information Files and the EASE1000 V2 USB drivers. 
 

• Please use Release 2.2.0 or later as the version of U8/U16 Development Tools. 

• Operating environment：Windows 7*, Windows 8.1*, Windows 10*   * 32-bit (x86) and 64-bit (x64) version. 

• Please log on as an administrator account. 

• When U8/U16 Development Tools existing in your PC, uninstall these programs at the beginning.  

For uninstallation, refer to Step #13. 

 
2-1. Extract the archives of the U8DevTool_Rx_xx_x.zip in the “ML62Q1000_MCU_StarterKit” folder that you copied in Step #1. 

*” Rx_xx_x” depends on the release version of the U8/U16 Development Tools. 
 

2-2. Double-click the U8DevInstaller.exe file in the “Setup” folder into which you extracted the U8DevTool_Rx_xx_x.zip. 
When this file is executed, the InstallShield Wizard will install the U8/U16 Development Tools software, the Multiple Flash Writer, 
the Device Information File and the EASE1000 V2 USB driver. 

 

• Follow the instructions of the InstallShield wizard to install.  

• Agree to “SOFTWARE LICENSE AGREEMENT for SOFTWARE DEVELOPMENT TOOLS”. 

• Do not change option settings. 

• Select “Standard” as “Setup Type” 
 

When the InstallShield Wizard displays the “InstallShield Wizard Completed” message box finally, close it. 
After that, installation has finished. 

 
3. Connecting 
3-1. As shown in figure 1 and figure 2, connect the ML62Q1577 Reference Board to the EASE1000 V2 On-Chip Emulator (hereinafter 

“EASE1000”). 
 

• Use the ML62Q1557 Reference Board by default settings. 
 

3-2. Connect the EASE1000 to PC using the USB cable. 
 

 
4. Installing the ML62Q1000 Blink LED Sample Program 
4-1. Extract the archives of the MCU_SampleProgram_vXXX.zip in the “ML62Q1000_MCU_ StarterKit” folder that you copied in Step 

#1. 
The ML62Q1000 Blink LED Sample Program (hereinafter “Blink LED Sample Program”) will be extracted into the 
“ML62Q1000_MCU_StarterKit\MCU_SampleProgram_vXXX\Software_LEXIDE” folder. 
 

                           *”vXXX” depends on the version of theML62Q1000 MCU Starter Kit Sample Program Package. 
 

 
 
 
 
 

5. Launching the LEXIDE-U16 
This section will take you through the process of Launching the LEXIDE-U16 Integrated Development Environment (hereinafter 
“LEXIDE-U16”) 
 

• For details regarding the LEXIDE-U16, refer to the “LEXIDE-U16 User’s manual”. 
Start Menu > U8 Software Tools Document > LEXIDE-U16 User’s Manual 

 
5-1. Launch the LEXIDE-U16 from the Start Menu of Windows. 

Start Menu > U8 Tools > LEXIDE-U16 
The LEXIDE-U16 will display [Select a directory as workspace] dialog box after displaying a Splash Screen. 

5-2. In the [Workspace] field of the [Select a directory as workspace] dialog box, select the 
“ML62Q1000_MCU_StarterKit\MCU_SampleProgram_vXXX\Software_LEXIDE” folder which was extracted the 
MCU_SampleProgram_vXXX.zip in Step #4-1. And click the [Launch]. 

*”vXXX” depends on the version of theML62Q1000 MCU Starter Kit Sample Program Package. 
 

 
 
 
 
 
 
 

Figure 3  Select a “Workspace” folder in the [Workspace] field  
       of the [Select a directory as workspace] dialog box. 

 
 

• When you specify a folder other than the above as the folder specified in the [Workspace] field, specify a folder that 

complies with the "Restrictions on Input Value" described in the "LEXIDE-U16 User's Manual". 
 

A little while, the LEXIDE-U16 will launch. 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 4  The LEXIDE-U16 after startup (screen when maximized). 
 
 

6. Importing the Blink LED Sample Program project 
This section will take you through the process of importting the Blink LED Sample Program project to the LEXIDE-U16. 

6-1. Select the [File] menu > [ Import…] menu command of the LEXIDE-U16. 
The [Import] dialog box will be opened. 

6-2. Select [General] > [Existing Projects into Workspace] in the [Import] dialog box and click [Next]. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 5  Select [General] > [Existing Projects into Workspace] in the [Import] dialog box. 
 
The [Import] dialog box will be opened. 
 

6-3. Select “ML62Q1000_MCU_StarterKit\MCU_SampleProgram_vXXX\Software_LEXIDE\0001_BlinkLED” folder in the [Select 
root directory] field of the [Import] dialog box. 
The selected folder contains the Blink LED Sample Program project file (”.cproject”，”.project”). 
 

                          *”vXXX” depends on the version of theML62Q1000 MCU Starter Kit Sample Program Package. 
 

 
 
 
  
 
 
 
 
 
 
 
 
 
 
 

Figure 6  Select “root directory” in the [Project path] of the [Import] dialog box. 
 

 
The Blink LED Sample Program project will be displayed in the [Import] dialog box (Fig 7). 
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6-4. Confirm that “0001_BlinkLED” displayed in the [Projects] field of the [Import] dialog box is checked and click the [Finish] button. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 7  Select “0001_BlinkLED” project in the [Import] dialog box. 
 
The "0001_BlinkLED" folder will be displayed in the [Project Explorer] of the LEXIDE-U16. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 8  The LEXIDE-U16 after loading the Blink LED Sample Program project (screen when maximized). 
 
 

7. Building the Blink LED Sample Program 
This section will take you through the process of building the Blink LED Sample Program. 

7-1. Confirm that “0001_BlinkLED Debug” is displayed in the [Launch Configuration] field of the LEXIDE-U16. 
 
 
 
 

Figure 9  The "Launch Configuration" field of the LEXIDE-U16. 
 

7-2. Click the [Build] button on the toolbar of the LEXIDE-U16 to build (compile, assemble and link) the Blink LED Sample Program . 
 
 
 
 
You will be able to see the message “Build Finished.” 
 
 

8. Start debugging  
Load the Blink LED Sample Program into the ML62Q1577, execute this sample program to the beginning of the main function, and 
start debugging. 

8-1. Select "Debug" in the [Launch Mode] field on the toolbar of the LEXIDE-U16. 
 
 
 
 
 

Figure 10  Select "Debug" in the [Launch Mode] field of the LEXIDE-U16. 
 

8-2. Click the [Launch in ‘Debug’ mode] button on the toolbar of the LEXIDE-U16. 
 
 
 
 
 
The LEXIDE-U16 will load the Blink LED Sample Program into ML62Q1577, reset ML62Q1577, execute this sample program, 
and break at the beginning of the main function. 
 
[Supplementary explanation] 
During the above processing, the LEXIDE-U16 will display the processing status at the bottom right. 
 
 
 
 
 

Figure 11  Displaying the processing status of the LEXIDE-U16. 
 
After that, the LEXIDE-U16 will display the dialog ("Confirm Perspective Switch" dialog) confirming the perspective switching 
shown in Fig. 12. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 
 
 

8-3. Click the [Yes] button in the [Confirm Perspective Switch] dialog. 
 
 
 
 
 
 
 

Figure 12  The [Confirm Perspective Switch] dialog. 
 

The LEXIDE-U16 will switch to the debugging perspective (hereinafter "the [Debug] perspective"). 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 13  The LEXIDE-U16 immediately after loading the Blink LED Sample Program  
and executing up to the main function (screen when maximized). 

 
 

9. Running the Blink LED Sample Program 
9-1. Click the [Resume (F8)] button on the toolbar of the LEXIDE-U16. 

 
 
 
 
 
The Blink LED Sample Program will be executed from the beginning of the main function, and the three LEDs on the ML62Q1577 
Reference Board will blink.  
 
 

10. Stopping the Blink LED Sample Program 
10-1. Click the [Suspend] button on the toolbar of the LEXIDE-U16. 

 
 
 
 
Execution of the Blink LED Sample Program will stop. 
 
 

11. Stop debugging 
11-1. Click the [Stop] button on the toolbar of the LEXIDE-U16 to stop debug. 

 
 
 
 
 
<Terminated> will be displayed in the [Debug] tab of the LEXIDE-U16. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 14  LEXIDE-U16 immediately after terminating Debug (screen when maximized). 
 

 
[Supplementary explanation] 
To return to the layout before debugging, click the [C/C++] perspective button on the right side of the toolbar 
 
 
 
 
 
 
 

12. Shut down 
< LEXIDE-U16 > 

12-1. Select the [File] menu > [Exit] menu command of the LEXIDE-U16 
The LEXIDE-U16will shut down. 

 
<Hardware > 

12-2. Disconnect the USB cable which is connected to the EASE1000 from your PC. 
 
 
 
 
 
 
 



 
 
 
 

13. Uninstallation 

• Uninstalling U8/U16 Development Tools Release 2.00.0 or later 

In order to uninstall, you should select the following programs from “Add or Remove Programs” of Control Panel. 

- U8/U16 Development Environment Setup : LAPIS Semiconductor U8/U16 Development Environment Setup 

 

You will be able to uninstall all of the bellow U8/U16 Development Tools. 

- U8/U16 Development Tools software (build tools) : LAPIS Semiconductor U8/U16 Development Tools 

- U8/U16 Development Tools software (GUI tools) : LAPIS Semiconductor U8/U16 Development Tools 

- Multiple Flash Writer   : LAPIS Semiconductor MWU16 Multiple Flash Writer 

- U8/U16 Device Information Files  : LAPIS Semiconductor U8/U16 Device Information Files 

- USB drivers    : U8/U16 Development Tools Driver 
 

• Uninstalling U8/U16 Development Tools Release 1.xx.x or earlier. 

In order to uninstall, you should select the following programs from “Add or Remove Programs” of Control Panel. 

- U8/U16 Development Tools software  : LAPIS Semiconductor U8/U16 Development Tools 

- U8/U16 Device Information Files  : LAPIS Semiconductor U8/U16 Device Information Files 

- U8/U16 Device Information Files  : LAPIS Semiconductor U8/U16 Device Information Files 

- USB drivers    : U8/U16 Development Tools Driver*1 

*1: There is not USB driver in the U8/U16 Development Tools Release 1.15.4 than earlier. 
 
 

14. The Software Development Support System 
When you need the latest version of the U8/U16 Development Tools software and the ML62Q1000 Series Reference Software, you 
can download the latest version from “LAPIS Semiconductor support site” (hereinafter “Support Site”) is a special website that 
gives registered users. 
Registration is required to access the site using an ID and Password. 
Navigate to the support page by clicking on a link on LAPIS Semiconductor's home page or by entering the URL in the browser's 
address bar. Then click on the 'Register' link. 

LAPIS Semiconductor support site URL 
https://www.lapis-semi.com/cgi-bin/MyLAPIS/regi/login.cgi 

 
 
 
 
 
 
 

* In order to download the software such as the software development support system, you need to register the 
serial number of the EASE1000 V2 at the time of registration.  
At the time of registration, select “Microcontroller / speech Synthesis LSI”, "EASE1000 V2 " and type "The 
serial number of EASE1000 V2" as follows. 
 

Category: Microcontroller / speech Synthesis LSI 
Development/evaluation tool name: EASE1000 V2 
The serial number of development tool: The serial number of EASE1000 V2 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

June 15, 2020 
FEXTSKBS01D62Q1577_StartGuide-02 

Copyright 2019-2020 LAPIS Semiconductor Co., Ltd. 

https://www.lapis-semi.com/cgi-bin/MyLAPIS/regi/login.cgi

