Dear customer

LAPIS Semiconductor Co., Ltd. ("LAPIS Semiconductor"), on the 1 day of October,
2020, implemented the incorporation-type company split (shinsetsu-bunkatsu) in which
LAPIS established a new company, LAPIS Technology Co., Ltd. (“LAPIS
Technology”) and LAPIS Technology succeeded LAPIS Semiconductor’s LSI business.

Therefore, all references to "LAPIS Semiconductor Co., Ltd.", "LAPIS Semiconductor"
and/or "LAPIS™ in this document shall be replaced with "LAPIS Technology Co., Ltd."

Furthermore, there are no changes to the documents relating to our products other than
the company name, the company trademark, logo, etc.

Thank you for your understanding.

LAPIS Technology Co., Ltd.
October 1, 2020
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Figure 1 ML62Q1000 LCD Starter Kit hardware configuration

m Use in a stand-alone
The ML62Q1747 Watch Sample Program (hereinafter “Watch Sample Program™) is being written in the flash memory at the time of
shipment.
The following description applies to use in a stand-alone.

USB cable

AC — USB power supply ™

ML62Q1747 LCD Application Board

Figure 2 Use in a stand-alone configuration

« AC - USB power supply are to be supplied by our customers.
If you connect the ML62Q1747 LCD Application Board to your PC by the USB cable, power is supplied to it.
* Use the ML62Q1747 LCD Application Board by default settings.

1. Connection and launch of the Watch Sample Program
1-1. As shown in figure 1 and figure 2, connect the USB cable to the ML62Q1747 LCD Application Board.
1-2. Connect the USB cable to power supply.

The Watch Sample Program will start and blink the display of “CONFIG” and time (PM 11:59:59).
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Figure 3 Display of the LCD after starting

1

3. Push the switch”SW1” of the ML62Q1747 LCD Application Board.
The Watch Sample Program counts time and displays time on LCD.
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Figure 4 Display of the LCD after pushing the switch”SW1" of the ML62Q1747 LCD Application Board.

« For more details regarding the method of setting time, refer to ML62Q1747 Watch Sample Program Operation Guide
which is included the “ML62Q1000 LCD Starter Kit Software Package” DVD.
If you set time, you must connect the ML62Q1747 LCD Application Board to PC.

< If you connect the ML62Q1747 LCD Application Board to PC, refer to step #5-3.

2. Shut down
2-1. Disconnect the USB cable from power supply.

« If you will reset ML62Q1747 during execution of the Watch Sample Program, you must change the jumper settings. For
more details regarding the jumper settings, refer to the “3.1 Use in a stand-alone configuration” of ML62Q1747 Watch
Sample Program Operation Guide which is included the “ML62Q1000 LCD Starter Kit Software Package” DVD.
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m  Use with the U8/U16 Development Tools
This section will take you through the process of building the Watch Sample Program, loading to the ML62Q1747 LCD Application
Board and running.
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Figure 5  Use with the U8/U16 Development Tools configuration

* Use the ML62Q1747 LCD Application Board by default settings.

3. Copy of ML62Q1000 LCD Starter Kit Software Package to your PC
3-1. Connect the “ML62Q1000 LCD Starter Kit Software Package” DVD into the DVD drive of your PC.
3-2. Copy the “ML62Q1000_LCD_StarterKit” folder in the DVD to the C drive’s root folder (C:\) of your PC.

* Please copy the “ML62Q1000_LCD_StarterKit” folder to the folder the name of which is using half-width characters
except space if you do not copy it to the C drive’s root folder (C:\) of your PC.

3-3. Eject the DVD from the DVD drive of your PC.

4. Installing U8/U16 Development Tools
This section will take you through the process of installing the U8/U16 Development Tools software, the Multiple Flash Writer, the
Device Information Files and the EASE1000 V2 USB drivers.

Please use Release 2.2.0 or later as the version of U8/U16 Development Tools.
* 32-bit (x86) and 64-bit (x64) version.

Operating environment: Windows 7*, Windows 8.1*, Windows 10*

Please log on as an administrator account.

When U8/U16 Development Tools existing in your PC, uninstall these programs at the beginning.

For uninstallation, refer to Step #15.

4-1. Extract the archives of the U8DevTool_Rx_xx_x.zip in the “ML62Q1000_LCD_StarterKit” folder that you copied in Step #3.
*7 Rx_xx_x" depends on the release version of the U8/U16 Development Tools.

4-2. Double-click the U8Devlnstaller.exe file in the “Setup” folder into which you extracted the U8DevTool_Rx_xx_x.zip.
When this file is executed, the InstallShield Wizard will install the U8/U16 Development Tools software, the Multiple Flash
Writer, the Device Information File and the EASE1000 V2 USB driver.

» Follow the instructions of the InstallShield wizard to install.
¢ Agree to “SOFTWARE LICENSE AGREEMENT for SOFTWARE DEVELOPMENT TOOLS”.
« Do not change option settings.

* Select “Standard” as “Setup Type”

When the InstallShield Wizard displays the “InstallShield Wizard Completed” message box finally, close it.
After that, installation has finished.

5. Connecting

5-1. As shown in figure 1 and figure 5, connect the ML62Q1747 LCD Application Board to the EASE1000 V2 On-Chip Emulator
(hereinafter “EASE1000”).

5-2. Connect the EASE1000 to PC using the USB cable.

5-3. Connect the ML62Q1747 LCD Application Board to PC using the USB cable.
If you have first connected the ML62Q1747 LCD Application Board to PC, the messages of the following Figure 6 and Figure 7
are displayed in sequence.

] ! Installing device driver software % * [l Device driver software was not successfully installed * *
Click here for status. Click here for details.

Figure 6 The USB driver installation message 1 Figure 7 The USB driver installation message 2

At this point, USB driver for the ML62Q1747 LCD Application Board is not successfully installed yet.

In this guide, the USB driver is not necessary for only supplying power to the ML62Q1747 LCD Application Board.
For more details regarding the installation of the USB driver for the ML62Q1747 LCD Application Board, refer to "*3.
Operating environment" of ML62Q1747 Watch Sample Program Operation Guide which is included the “ML62Q1747
LCD Starter Kit Software Package” DVD.

6. Installing the ML62Q1747 Watch Sample Program
6-1. Extract the archives of the WatchSample_Vxxx.zip in the “ML62Q1000_LCD_StarterKit” folder that you copied in Step #3.
The Watch Sample Program will be extracted into the “ML62Q1000_LCD_StarterKit\WatchSample_Vxxx\Software LEXIDE”
folder.
*7 \/xxx” depends on the version of the Watch Sample Program.



7. Launching the LEXIDE-U16

This section will take you through the process of launching the LEXIDE-U16 Integrated Development Environment (hereinafter
“LEXIDE-U16")

« For details regarding the LEXIDE-U186, refer to the “LEXIDE-U16 User’s manual”.
Start Menu > U8 Tools > U8 Software Tools Document > LEXIDE-U16 User’s Manual

7-1. Launch the LEXIDE-U16 from the Start Menu.
Start Menu > U8 Tools > LEXIDE-U16
The LEXIDE-U16 will display [Select a directory as workspace] dialog box after displaying a Splash Screen.
7-2.

In the [Workspace] field of the [Select a directory as workspace] dialog box, select the

“ML62Q1000_LCD_StarterKit\WatchSample_Vxxx\Software_LEXIDE” folder which was extracted the WatchSample_Vxxx.zip
in Step #6-1.

And click the [Launch].

*” \/xxx” depends on the version of the Watch Sample Program.

Select a directory as workspace

LEXIDE-U16 ses the workspace directory to store its preferences and development artfacts.
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O] Use this as the default and do not ask again
» Recent Workspaces

Figure 8 Select a “Workspace” folder in the [Workspace] field
of the [Select a directory as workspace] dialog box.

Cancel

* When you specify a folder other than the above as the folder specified in the [Workspace] field, specify a folder that
complies with the “'Restrictions on Input Value' described in the "LEXIDE-U16 User's Manual®.

A little while, the LEXIDE-U16 will launch.
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Figure 9 The LEXIDE-U16 immediately after startup (screen when maximized).

8. Importing the ML62Q1747 Watch Sample Program project

This section will take you through the process of importing the Watch Sample Program project to the LEXIDE-U16.
Select the [File] menu > [ Import...] menu command of the LEXIDE-U16.
The [Import] dialog box will be opened.

8-2. Select [General] > [Existing Projects into Workspace] in the [Import] dialog box and click [Next].
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Figure 10  Select [General] > [Existing Projects into Workspace] in the [Import] dialog box.

< Back Einish Cancel

The [Import] dialog box will be opened.

Select “ML62Q1000_LCD_StarterKit\WatchSample_Vxxx\Software_LEXIDE\Watch” folder in the [Select root directory] field
of the [Import] dialog box.

The selected folder contains the Watch Sample Program project file (”.cproject”, ”.project”).

*"\/xxx” depends on the version of the Watch Sample Program.
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Figure 11  Select “root directory” in the [Project path] of the [Import] dialog box.

The Watch Sample Program project will be displayed in the [Import] dialog box (Fig 12).
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8-4. Confirm that “Watch” displayed in the [Projects] field of the [Import] dialog box is checked and click the [Finish] button.

Import Projects B

)

Pelect a directory to search for existing Eclipse projects.

@ Select root directory: | C:\ML6201000_LCD_Starterk t\WatchSample_V200\Sof tware_LEXIDE\Watch ][ Browse

O Select archive file Browse.

Projects:

W (€ 01000 L0 St e V20 St OB )| =T

Deselect All

Refresh

Options.

[ Search for nested projects

[ Gopy projects into workspace

[ Hide projects that alreacly existn the workspace.
Working sets

[1Add project to working sets New
Working sets Selct.

@ <Back Next> I Finish I

Cancel

Figure 12  Select “Watch” project in the [Import] dialog box.

The "Watch" folder will be displayed in the [Project Explorer] of the LEXIDE-U16.
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Figure 13 The LEXIDE-U16 after loading the Watch Sample Program project (screen when maximized).

9. Building the ML62Q1747 Watch Sample Program
This section will take you through the process of building the Watch Sample Program.
9-1. Confirm that " Watch Debug " is displayed in the “Launch Configuration" field of the LEXIDE-U16.
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Figure 14  The "Launch Configuration” field of the LEXIDE-U16.

9-2. Click the [Build] button on the toolbar of the LEXIDE-U16 to build (compile, assemble, and link) the Watch Sample Program.
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You will be able to see the message “Build Finished.”

10. Start debugging

Load the Watch Sample Program into the ML62Q1747, execute this sample program to the beginning of the main function, and
start debugging.

10-1. Select "Debug" in the [Launch Mode] field on the toolbar of the LEXIDE-U16.
} Software_LEXIDE - LEXIDE-U16
File Edit Source Refactor Mavigate Search Project Run LAPIS LAPISDebug Window
|g@ Debug ~ || [£] Watch Debug - ‘ !
Figure 15 Select "Debug" in the [Launch Mode] field of the LEXIDE-U16.
10-2. Click the [Launch in ‘Debug’ mode] button on the toolbar of the LEXIDE-U16.
ftware_LEXIDE - LEXIDE-U16
urce Refactor Navigate Search Project Run LAPIS LAPISDebug Window
‘ 45 Debug v ‘ ‘ [] Watch Debug v
The LEXIDE-U16 will load the Watch Sample Program into ML62Q1747, reset ML62Q1747, execute this sample program, and
break at the beginning of the main function.
[Supplementary explanation]
During the above processing, the LEXIDE-U16 will display the processing status at the bottom right.
2 Conscle &2 & 8 a =B -8-=n0
: Launching Watch Debug: (31%) -
Figure 16 Displaying the processing status of the LEXIDE-U16.
After that, LEXIDE-U16 will display the dialog ("Confirm Perspective Switch" dialog) confirming the perspective switching
shown in Fig. 17.
10-3.

Click the [Yes] button in the [Confirm Perspective Switch] dialog.

[ Confirm Perspective Switch

@ This kind of launch is cenfigured to open the Debug perspective when it suspends.

This Debug perspective is designed to support application debugging. It incerporates
views for displaying the debug stack, variables and breakpaint management.

Do you want ta open this perspective now?

[ Remember my decision

Figure 17 The [Confirm Perspective Switch] dialog



LEXIDE-U16 will switch to the debugging perspective (hereinafter “the [Debug] perspective").
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Figure 18 LEXIDE-U16 immediately after loading the Watch Sample Program
and executing up to the main function (screen when maximized)

11. Running the ML62Q1747 Watch Sample Program
11-1. Click the [Resume (F8)] button on the toolbar of the LEXIDE-U16.
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The Watch Sample Program will be executed from the beginning of the main function and start in the same way as when it is run

standalone.

12.  Stopping the ML62Q1747 Watch Sample Program
12-1. Click the [Suspend] button on the toolbar of the LEXIDE-U16.
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Execution of the Watch Sample Program will stop.

13. Stop debugging
13-1. Click the [Stop] button on the toolbar of the LEXIDE-U16 to terminate debug.
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<Terminated> will be displayed in the [Debug] tab of the LEXIDE-U16.
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Figure 19 LEXIDE-U16 immediately after terminating Debug (screen when maximized).

[Supplementary explanation]
To return to the layout before debugging, click the [C/C++] perspective button on the right side of the toolbar

i

14.  Shut down
< LEXIDE-U16 >
14-1. Select the [File] menu > [Exit] menu command of the LEXIDE-U16
The LEXIDE-U16will shut down.

<Hardware >
14-2. Disconnect the USB cable which is connected to the ML62Q1747 LCD Application Board from your PC.
14-3. Disconnect the USB cable which is connected to the EASE1000 from your PC.
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Uninstallation

 Uninstalling U8/U16 Development Tools Release 2.00.0 or later

In order to uninstall, you should select the following programs from “Add or Remove Programs” of Control Panel.

- U8/U16 Development Environment Setup : LAPIS Semiconductor U8/U16 Development Environment Setup

You will be able to uninstall all of the bellow U8/U16 Development Tools 2.00.0 or later.

- U8/U16 Development Tools software (build tools) : LAPIS Semiconductor U8/U16 Development Tools

- U8/U16 Development Tools software (GUI tools) : LAPIS Semiconductor U8/U16 Development Tools

- Multiple Flash Writer : LAPIS Semiconductor MWU16 Multiple Flash Writer

- U8/U16 Device Information Files : LAPIS Semiconductor U8/U16 Device Information Files
- USB drivers : U8/U16 Development Tools Driver

« Uninstalling U8/U16 Development Tools Release 1.xx.x or earlier.

In order to uninstall, you should select the following programs from “Add or Remove Programs” of Control Panel.

- U8/U16 Development Tools software : LAPIS Semiconductor U8/U16 Development Tools

- U8/U16 Device Information Files : LAPIS Semiconductor U8/U16 Device Information Files
- U8/U16 Device Information Files : LAPIS Semiconductor U8/U16 Device Information Files
- USB drivers : U8/U16 Development Tools Driver™

*1: There is not USB driver in the U8/U16 Development Tools Release 1.15.4 than earlier.

The Software Development Support System
When you need the latest version of the U8/U16 Development Tools software and the ML62Q1000 Series Reference Software,
you can download the latest version from “LAPIS Semiconductor support site” (hereinafter “Support Site”) is a special website
that gives registered users.

Registration is required to access the site using an 1D and Password.
Navigate to the support page by clicking on a link on LAPIS Semiconductor's home page or by entering the URL in the browser's
address bar. Then click on the 'Register" link.

LAPIS Semiconductor support site URL
https://www. lapis-semi.com/cgi-bin/MyLAPIS/regi/login.cgi

* In order to download the software such as the software development support system, you need to register the
serial number of the EASE1000 V2at the time of registration.
At the time of registration, select “Microcontroller / speech Synthesis LSI”, "EASE1000 V2 " and type "The
serial number of EASE1000 V2" as follows.

Category: Microcontroller / speech Synthesis LSI
Development/evaluation tool name: EASE1000 V2
The serial number of development tool: The serial number of EASE1000 V2
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