
Dear customer 
 
LAPIS Semiconductor Co., Ltd. ("LAPIS Semiconductor"), on the 1st day of October, 
2020, implemented the incorporation-type company split (shinsetsu-bunkatsu) in which 
LAPIS established a new company, LAPIS Technology Co., Ltd. (“LAPIS 
Technology”) and LAPIS Technology succeeded LAPIS Semiconductor’s LSI business. 
 
Therefore, all references to "LAPIS Semiconductor Co., Ltd.", "LAPIS Semiconductor" 
and/or "LAPIS" in this document shall be replaced with "LAPIS Technology Co., Ltd." 
 
Furthermore, there are no changes to the documents relating to our products other than 
the company name, the company trademark, logo, etc.  
 
Thank you for your understanding. 
 

LAPIS Technology Co., Ltd. 
October 1, 2020 
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Figure 1  ML62Q1000 Capacitive Switch Starter Kit hardware configuration 
 
■ Use in a stand-alone 

The ML62Q1367 DTMF Tone Generator Sample Program (hereinafter “DTMF Sample Program”) is being written in the flash 
memory at the time of shipment.  
The following description applies to use in a stand-alone. 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 2  Use in a stand-alone configuration 

 

• AC – USB power supply are to be supplied by our customers.  

If you connect the ML62Q1367 Capacitive Switch Application Board to your PC by the USB cable, power is supplied to 

it. 

 
1. Connection and launch of the DTMF Sample Program 
1-1. As shown in figure 1 and figure 2, connect the speaker and the USB cable to the ML62Q1367 Capacitive Switch Application 

Board. 
1-2. Connect the USB cable to power supply. 

The DTMF Sample Program will start, display “LAPIS” on the LCD and sound a beep. 
 

 
 
 

Figure 3  Display of the LCD after starting 

 

1-3. Touch a capacitive switch key of the ML62Q1367 Capacitive Switch Application Board.  
The DTMF Sample Program sounds a DTMF tone corresponding to a touched capacitive switch key and displays a character to 
on the LCD. 
 
 
 
 
 

Figure 4  Display example of the LCD after touching capacitive switch key [TSW12] 

  of the ML62Q1367 Capacitive Switch Application Board. 

 
2. Shut down 
2-1. Disconnect the USB cable from power supply. 
 

 
 
 
 
■ Use with the U8/U16 Development Tools 

This section will take you through the process of building the DTMF Sample Program, loading to the ML62Q1367 Capacitive Switch 
Application Board and running. 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 5  Use with the U8/U16 Development Tools configuration 

 
 
3. Copy of ML62Q1000 Capacitive Switch Starter Kit Software Package to your PC 
3-1. Insert the “ML62Q1000 Capacitive Switch Starter Kit Software Package” DVD into the DVD drive of your PC. 
3-2. Copy the “ML62Q1000_CAP_Switch_StarterKit” folder in the DVD to the C drive’s root folder (C:\) of your PC. 

 

• Please copy the “ML62Q1000_CAP_Switch_StarterKit” folder to the folder the name of which is using half-width 

characters except space if you do not copy it to the C drive’s root folder (C:\) of your PC. 
 

3-3. Eject the DVD from the DVD drive of your PC. 

 
4. Installing of U8/U16 Development Tools 

This section will take you through the process of installing the U8/U16 Development Tools software, the Multiple Flash Writer, 
the Device Information Files and the EASE1000 V2 USB drivers. 

 

• Please use Release 2.2.0 or later as the version of U8/U16 Development Tools. 

• Operating environment：Windows 7*, Windows 8.1*, Windows 10*   * 32-bit (x86) and 64-bit (x64) version. 

• Please log on as an administrator account. 

• When U8/U16 Development Tools existing in your PC, uninstall these programs at the beginning.  

For uninstallation, refer to Step #15. 

 
4-1. Extract the archives of the U8DevTool_Rx_xx_x.zip in the “ML62Q1000_CAP_Switch_StarterKit” folder that you copied in 

Step #3. 
*” Rx_xx_x” depends on the release version of the U8/U16 Development Tools. 

 
4-2. Double-click the U8DevInstaller.exe file in the “Setup” folder into which you extracted the U8DevTool_Rx_xx_x.zip. 

When this file is executed, the InstallShield Wizard will install the U8/U16 Development Tools software, the Multiple Flash 
Writer, the Device Information File and the EASE1000 V2 USB driver. 
 

• Follow the instructions of the InstallShield wizard to install.  

• Agree to “SOFTWARE LICENSE AGREEMENT for SOFTWARE DEVELOPMENT TOOLS”. 

• Do not change option settings. 

• Select “Standard” as “Setup Type” 
 
When the InstallShield Wizard displays the “InstallShield Wizard Completed” message box finally, close it. 
After that, installation has finished. 

 
5. Connecting 
5-1. As shown in figure 1 and figure 5, connect the ML62Q1367 Capacitive Switch Application Board to the EASE1000 V2 On-Chip 

Emulator (hereinafter “EASE1000”). 
5-2. Connect the EASE1000 to PC using the USB cable. 
5-3. Connect the speaker to the ML62Q1367 Capacitive Switch Application Board. 
5-4. Connect the ML62Q1367 Capacitive Switch Application Board to PC using the USB cable. 

 
 

6. Installing the DTMF Sample Program 
6-1. Extract the archives of the CAP_Switch_SampleProgram_Vxxx.zip in the “ML62Q1000_CAP_Switch_StarterKit” folder that 

you copied in Step #3.ML62Q1000 Capacitive Switch Starter Kit Sample Programs including the ML62Q1367 DTMF Tone 
Generator Sample Program will be extracted into the 
“ML62Q1000_CAP_Switch_StarterKit\CAP_Switch_SampleProgram_Vxxx\Software” folder. 

*” Vxxx” depends on the version of the ML62Q1000 Capacitive Switch Starter Kit Sample Program Package. 
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7. Launching the LEXIDE-U16 
This section will take you through the process of launching the LEXIDE-U16 Integrated Development Environment (hereinafter 
“LEXIDE-U16”) 

 

• For details regarding the LEXIDE-U16, refer to the “LEXIDE-U16 User’s manual”. 
Start Menu > U8 Tools > U8 Software Tools Document > LEXIDE-U16 User’s Manual 

 
7-1. Launch the LEXIDE-U16 from the Start Menu. 

Start Menu > U8 Tools > LEXIDE-U16 
The LEXIDE-U16 will display [Select a directory as workspace] dialog box after displaying a Splash Screen. 

7-2. In the [Workspace] field of the [Select a directory as workspace] dialog box, select the 
“ML62Q1000_CAP_Switch_StarterKit\CAP_Switch_SampleProgram_Vxxx\Software” folder which was extracted the 
CAP_Switch_SampleProgram_Vxxx.zip in Step #6-1. 
And click the [Launch]. 

*” Vxxx” depends on the version of the ML62Q1000 Capacitive Switch Starter Kit Sample Program Package. 
 
 
 
 
 
 
 
 

Figure 6  Select a “Workspace” folder in the [Workspace] field  
       of the [Select a directory as workspace] dialog box. 

 
• When you specify a folder other than the above as the folder specified in the [Workspace] field, specify a folder that 

complies with the "Restrictions on Input Value" described in the "LEXIDE-U16 User's Manual". 
 
A little while, the LEXIDE-U16 will launch. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 7  The LEXIDE-U16 immediately after startup (screen when maximized). 
 

 
8. Importing the ML62Q1367 DTMF Tone Generator Sample Program project 

This section will take you through the process of importing the DTMF Sample Program project to the LEXIDE-U16. 
8-1. Select the [File] menu > [ Import…] menu command of the LEXIDE-U16. 

The [Import] dialog box will be opened. 
8-2. Select [General] > [Existing Projects into Workspace] in the [Import] dialog box and click [Next]. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 8  Select [General] > [Existing Projects into Workspace] in the [Import] dialog box. 
 

The [Import] dialog box will be opened. 
 

8-3. Select 
“ML62Q1000_CAP_Switch_StarterKit\CAP_Switch_SampleProgram_Vxxx\Software\01_Dtmf_Vyyy\Software_LEXIDE\DtmfS
ample” folder in the [Select root directory] field of the [Import] dialog box. 
The selected folder contains the DTMF Sample Program project file (”.cproject”，”.project”). 

 
*” Vxxx” depends on the version of the ML62Q1000 Capacitive Switch Starter Kit Sample Program Package.                           
*”Vyyy” depends on the version of the DTMF Sample Program. 
 

 
 
 
  
 
 
 
 
 
 
 
 
 
 
 

Figure 9  Select “root directory” in the [Project path] of the [Import] dialog box. 
 
The DTMF Sample Program project will be displayed in the [Import] dialog box (Fig 10). 

 
 
 
 

8-4. Confirm that “DtmfSample” displayed in the [Projects] field of the [Import] dialog box is checked and click the [Finish] button. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 10  Select “DtmfSample” project in the [Import] dialog box. 
 
 

The "DtmfSample " folder will be displayed in the [Project Explorer] of the LEXIDE-U16. 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 11  The LEXIDE-U16 after loading the DTMF Sample Program project (screen when maximized). 
 
 

9. Building the ML62Q1367 DTMF Tone Generator Sample Program 
This section will take you through the process of building the DTMF Sample Program 

9-1. Confirm that " DtmfSample debug" is displayed in the "Launch Configuration" field of the LEXIDE-U16. 
 
 
 
 

Figure 12  The "Launch Configuration" field of the LEXIDE-U16. 
 

9-2. Click the [Build] button on the toolbar of the LEXIDE-U16 to build (compile, assemble, and link) the DTMF Sample Program. 
 
 

 
 
 
You will be able to see the message “Build Finished.” 
 
 

10. Start debugging 
Load the DTMF Sample Program into the ML62Q1367, execute this sample program to the beginning of the main function, and 
start debugging. 

10-1. Select "Debug" in the [Launch Mode] field on the toolbar of the LEXIDE-U16. 
 
 
 
 

Figure 13  Select "Debug" in the [Launch Mode] field of the LEXIDE-U16. 
 

10-2. Click the [Launch in ‘Debug’ mode] button on the toolbar of the LEXIDE-U16. 
 
 
 
 
The LEXIDE-U16 will load the DTMF Sample Program into ML62Q1367, reset ML62Q1367, execute this sample program, and 
break at the beginning of the main function. 
 
[Supplementary explanation] 
During the above processing, the LEXIDE-U16 will display the processing status at the bottom right. 

 
 
 
 
 

Figure 14  Displaying the processing status of the LEXIDE-U16. 
 
 
After that, LEXIDE-U16 will display the dialog ("Confirm Perspective Switch" dialog) confirming the perspective switching 
shown in Fig. 15. 
 

10-3. Click the [Yes] button in the [Confirm Perspective Switch] dialog. 
 

 
 
 
 
 
 

Figure 15  The [Confirm Perspective Switch] dialog 
 

 
 
 
 
 



 
 
 
 
LEXIDE-U16 will switch to the debugging perspective (hereinafter "the [Debug] perspective"). 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 16  LEXIDE-U16 immediately after loading the DTMF Sample Program  
and executing up to the main function (screen when maximized) 

 
 

11. Running the ML62Q1367 DTMF Tone Generator Sample Program 
11-1. Click the [Resume (F8)] button on the toolbar of the LEXIDE-U16. 

 
 
 
 
The DTMF Sample Program will be executed from the beginning of the main function and start in the same way as when it is run 
standalone. 
 
 

12. Stopping the ML62Q1367 DTMF Tone Generator Sample Program  
12-1. Click the [Suspend] button on the toolbar of the LEXIDE-U16. 

 
 
 
 
 

Execution of the DTMF Sample Program will stop. 
 
 

13. Terminating Debug 
13-1. Click the [Stop] button on the toolbar of the LEXIDE-U16 to terminate debug. 
 
 
 
 
 

<Terminated> will be displayed in the [Debug] tab of the LEXIDE-U16. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 17  LEXIDE-U16 immediately after terminating Debug (screen when maximized) 
 
 
[Supplementary explanation] 
To return to the layout before debugging, click the [C/C++] perspective button on the right side of the toolbar 
 
 
 
 
 
 
 

14. Shut down 
<LEXIDE-U16 > 

14-1. Select the [File] menu > [Exit] menu command of the LEXIDE-U16 
The LEXIDE-U16will shut down. 
 

<Hardware > 
14-2. Disconnect the USB cable which is connected to the ML62Q1367 Capacitive Switch Application Board from your PC. 
14-3. Disconnect the USB cable which is connected to the EASE1000 from your PC. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 
 
 

15. Uninstallation 

• Uninstalling U8/U16 Development Tools Release 2.00.0 or later 

In order to uninstall, you should select the following programs from “Add or Remove Programs” of Control Panel. 

- U8/U16 Development Environment Setup : LAPIS Semiconductor U8/U16 Development Environment Setup 

 

You will be able to uninstall all of the bellow U8/U16 Development Tools. 

- U8/U16 Development Tools software (build tools) : LAPIS Semiconductor U8/U16 Development Tools 

- U8/U16 Development Tools software (GUI tools) : LAPIS Semiconductor U8/U16 Development Tools 

- Multiple Flash Writer   : LAPIS Semiconductor MWU16 Multiple Flash Writer 

- U8/U16 Device Information Files  : LAPIS Semiconductor U8/U16 Device Information Files 

- USB drivers    : U8/U16 Development Tools Driver 
 

• Uninstalling U8/U16 Development Tools Release 2.00.0 than earlier. (Not include Release 2.00.0) 

In order to uninstall, you should select the following programs from “Add or Remove Programs” of Control Panel. 

- U8/U16 Development Tools software  : LAPIS Semiconductor U8/U16 Development Tools 

- U8/U16 Device Information Files  : LAPIS Semiconductor U8/U16 Device Information Files 

- U8/U16 Device Information Files  : LAPIS Semiconductor U8/U16 Device Information Files 

- USB drivers    : U8/U16 Development Tools Driver*1 

*1: There is not USB driver in the U8/U16 Development Tools Release 1.15.4 than earlier. 
 
 

16. The Software Development Support System 
When you need the latest version of the U8/U16 Development Tools software and the ML62Q1000 Series Reference Software, 
you can download the latest version from “LAPIS Semiconductor support site” (hereinafter “Support Site”) is a special website 
that gives registered users. 
Registration is required to access the site using an ID and Password. 
Navigate to the support page by clicking on a link on LAPIS Semiconductor's home page or by entering the URL in the browser's 
address bar. Then click on the 'Register' link. 

LAPIS Semiconductor support site URL 
https://www.lapis-semi.com/cgi-bin/MyLAPIS/regi/login.cgi 

 
 
 
 
 
 
 

* In order to download the software such as the software development support system, you need to register the 
serial number of the EASE1000 V2at the time of registration.  
At the time of registration, select “Microcontroller / speech Synthesis LSI”, "EASE1000 V2 " and type "The 
serial number of EASE1000 V2" as follows. 
 

Category: Microcontroller / speech Synthesis LSI 
Development/evaluation tool name: EASE1000 V2 
The serial number of development tool: The serial number of EASE1000 V2 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

https://www.lapis-semi.com/cgi-bin/MyLAPIS/regi/login.cgi
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Appendices Figure 2. DTMF Sample Program key’s sheet 

Appendices Figure 3. Blank sheet  

Appendices Figure 1 
The ML62Q1367 Capacitive Switch Application Board  

which is inserted the DTMF Sample Program key’s sheet. 


